Click Here -> Please Consider Making a PayPal Contribution to the FordSix Forum!
2019 Contributors:
NJwpod, 1strodeo, mightynorseman, maxtrux, 6d7coupe, broncr, Phase3, 68Flareside240, bmbm40,
mustang6, WorldChampGramp, justintendo, BigBlue94, ags290, motorsickle1130, Rooster, ousooner919, ethanperry
rzcrisis, DoctorC, jamyers, Motorboy, fastpat, Silverback280, chad


<<< New Site Update >>>

Search found 9 matches

by bluesmokebloke
Thu Aug 02, 2018 8:05 am
Forum: 144-250 "Small Block" Six Performance
Topic: White smoke, needs choke when hot
Replies: 4
Views: 723

Re: White smoke, needs choke when hot

Thanks for the reply! Yeah, I'm getting 150 from all cylinders. It seems like steam to me too. I'm going to try retorquing the head today.
by bluesmokebloke
Wed Aug 01, 2018 6:01 pm
Forum: 144-250 "Small Block" Six Performance
Topic: White smoke, needs choke when hot
Replies: 4
Views: 723

White smoke, needs choke when hot

Hi all, hopefully this is a simple one for the gurus to troubleshoot. I'm no mechanic, and am thoroughly stumped. A little background: I have a '65 200ci in my '63 Falcon, with an Offy tripower intake and 3 Webers. The middle carb has a choke, the outers do not and those are set to kick in around 1/...
by bluesmokebloke
Wed Sep 04, 2013 10:20 am
Forum: Transmission & Drivetrain
Topic: Lokar C4 Shifter linkage trouble
Replies: 3
Views: 1450

Re: Lokar C4 Shifter linkage trouble

Thanks very much for the reply. Honestly I hadn't considered rod flex. I suspect there's also slop at both ends, plus the column arm - all adding up to a linkage too sloppy to shift into park. I got sidetracked for a few weeks but will try again to get this sorted out soon, with a fresh perspective.
by bluesmokebloke
Mon Aug 12, 2013 5:11 pm
Forum: Transmission & Drivetrain
Topic: Lokar C4 Shifter linkage trouble
Replies: 3
Views: 1450

Lokar C4 Shifter linkage trouble

Has anyone successfully used the Lokar ACA-1801 C4 column shift linkage? I'm installing one on my 63' Falcon after a 2-speed Fordomatic to C4 swap. It seems like it should be simple, but I'm at wits end trying to adjust it for smooth operation. I have a couple bends in the rod to make kind of an S s...
by bluesmokebloke
Tue May 29, 2012 10:54 am
Forum: 144-250 "Small Block" Six Performance
Topic: Offy linkage missing parts
Replies: 10
Views: 1290

Re: Offy linkage missing parts

Thanks, I really appreciate that. I'd take you up on it, but I did cut out the bellcranks and they seem to be working out alright. I'm keeping the stock linkage and need to bend a 1/4" threaded rod to actuate the arms, but I'm pretty optimistic. Before starting I studied lots of great tripower ...
by bluesmokebloke
Fri May 25, 2012 3:16 pm
Forum: 144-250 "Small Block" Six Performance
Topic: Offy linkage missing parts
Replies: 10
Views: 1290

Re: Offy linkage missing parts

Haven't heard back from Exeter yet, so on the long weekend I'll try to cut these pieces from sheet aluminum. I measured the manifold length for reference and used the pic above to make a template:
My Template (PDF, 225kb)

Can't wait to fire this baby up.
by bluesmokebloke
Mon May 21, 2012 4:36 pm
Forum: 144-250 "Small Block" Six Performance
Topic: Offy linkage missing parts
Replies: 10
Views: 1290

Re: Offy linkage missing parts

Thanks vssman! I finally had a chance to call Exeter, and they will check with Offy in the morning. It sounds promising.

I also learned the "v-shaped levers" are bellcranks. :oops:
by bluesmokebloke
Fri May 18, 2012 12:15 pm
Forum: 144-250 "Small Block" Six Performance
Topic: Offy linkage missing parts
Replies: 10
Views: 1290

Re: Offy linkage missing parts

Thanks, that's a good idea. I'll try calling Offenhauser first.

I bought the kit as a package with the motor, header and trans, and had no idea this kit retails for over $300. There's no way I'm shelling out that much dough!
by bluesmokebloke
Fri May 18, 2012 11:32 am
Forum: 144-250 "Small Block" Six Performance
Topic: Offy linkage missing parts
Replies: 10
Views: 1290

Offy linkage missing parts

Hi guys, Long-time lurker here. Thanks for several years of helpful posts. I just swapped the worn 170 & Fordo in my 63 Falcon sedan with a rebuilt 200 and C4. The 200 has the Offy adapter, on which I'll be mounting 3 Webers, as many have done. Here's my issue: All the linkage parts came in a ca...