Click Here -> Please Consider Making a PayPal Contribution to the FordSix Forum!
2019 Contributors:
NJwpod, 1strodeo, mightynorseman, maxtrux, 6d7coupe, broncr, Phase3, 68Flareside240, bmbm40,
mustang6, WorldChampGramp, justintendo, BigBlue94, ags290, motorsickle1130, Rooster, ousooner919, ethanperry
rzcrisis, DoctorC, jamyers, Motorboy, fastpat, Silverback280, chad


<<< New Site Update >>>

91 F150 runs lousy- i want to understand EFI

Moderator: Mod Squad

hertfordnc
New Member
Posts: 2
Joined: Fri Feb 24, 2017 9:21 am

91 F150 runs lousy- i want to understand EFI

Post #1 by hertfordnc » Mon Nov 04, 2019 11:33 am

I have a very nice 91 F150 with only 90,000 original miles. Two years ago i replaced the side cover and valve cover gaskets and it has not run right since. No power, stalls, etc. I've looked hard at everything i touched and followed peoples suggestions but nothing is working

When i get some free time (not often) i come back to it and keep trying to find the problem. I've looked at everything. Posted on various forum and facebook groups. People just throw out random suggestions.

I've looked at timing and plug wires, all the vac lines, I changed the fuel pressure regulator.

I've had not luck getting the early OBD to work.

At this point I am looking for a complete breakdown of the EFI system and how it works. I see vac lines going all over and I assume a lot of them are not critical to engine function. I want to understand what all the critical components are and what they do.

I am no longer focused on that i might have touched. I'm just to go throgh the whole system, starting with fuel pressure.

I would be grateful for any suggestions.

User avatar
bubba22349
Global Moderator
Posts: 9177
Joined: Sun Jan 03, 2010 4:46 pm
Location: Flagstaff, Az. 86005 near the old Route 66

Re: 91 F150 runs lousy- i want to understand EFI

Post #2 by bubba22349 » Mon Nov 04, 2019 8:23 pm

Can you post some pictures showing all the vacuum lines and electrical conections. On my 1994 had some troubles like that too. Started running rough one weekend setting and ideling this was just after I cleaned the battery cables and charged the battery. On mine it turned out to be partly the vacuum lines, and mostly dirty and loose electrical connects on the solenoid's that are mounted on the valve cover. After going through all the electrical every one of the conections, installing all new vacuum lines, plus a few tune up parts and a new oxygen sensor it ran better than the day I bought it (used 4 years before with 112,000 miles). I also used an analog volt / ohm meter to read the codes. Good luck :thumbup: :nod:
A bad day Drag Racing is still better than a good day at work!

I am still hunting for a project car to build but with my current low budget it's not looking so good. My Ex- Fleet of Sixes these are all long gone! :bang: 1954 Customline 223 3 speed with O/D, 1963 Fairlane project drag car with BB6, 1977 Maverick 250 with C4, 1994 F-150 a 300 with 5 speed.

User avatar
MechRick
Registered User
Posts: 899
Joined: Wed Jan 04, 2012 7:43 pm
Location: Las Vegas, NV

Re: 91 F150 runs lousy- i want to understand EFI

Post #3 by MechRick » Mon Nov 04, 2019 8:24 pm

The first step is to do a KOEO (key on engine off) KOER (key on engine running) test. All you need to do this is a jumper wire.

With the pointy part of the diagnostic connector (located on the left side of the engine compartment close to the PCM and fuel pump relays) facing up, signal return is the connector on the top right (gray/red). Jump that to the single wire pigtail (also known as self test input, or STI, white/purple). This will make the check engine lamp flash. It will also flash a test lamp with the alligator clip hooked to battery positive and the pointy end in the diagnostic connector terminal one step down and one step to the left of signal return (pink/light green wire).

I've always remembered it this way: Throw a soccer ball in the upper right window of the 'house' and it will roll out the center left door.

Anyway, your truck should have a check engine lamp. Once the jumper is installed, turn the key on, engine off, and the computer will flash out codes.

The format for the KOEO test is: hard fault | separator | history fault

A pass is indicated by: 11 | 10 | 11 which is two slow flashes, a pause, one quick flash, another pause, and two slow flashes.

As an example, if it flashed six slow flashes, one slow flash, a pause, one quick flash, pause, two slow flashes, that would indicate hard fault code 61, flagging a right-now problem with the engine coolant sensor.

A history fault with the same code would be two slow flashes, one quick flash, three slow flashes and one slow flash.

If you don't see it on the first go round, the computer always repeats the sequence.

Hard faults should be addressed immediately. If it's a history code, warm up the engine and do a running test. Hookup is the same, start the engine.

Format for KOER test is: engine identifier | separator | fault code

The engine identifier will flash a number of times that is half of the engine's cylinders. Our sixes will flash three times.

When it does this, the engine computer will look for inputs that you will need to provide. Grab the steering wheel and crank it left and right (power steering pressure switch), press the brake pedal (brake switch), cycle the overdrive cancel switch (if equipped). If you don't do this, the EEC will assume they don't function properly and trip false codes.

The computer will look at various signals, open the egr valve, and possibly request a stab of the throttle. If it wants you to do this, it will flash the check engine lamp once.

After all that, the idle will settle down and the computer will flash codes. There will probably be several codes. Post them here.
1994 F150, 4.9L/ZF 5 speed, C-Vic police driveshaft
EFI head w/mild port work, 3 angle valve job
1996 long block, stock pistons, ARP rod bolts
Stock cam, aluminum cam gear
Hedman header, full mandrel bent duals, crossover, super turbos
http://fordsix.com/forum/viewtopic.php?f=2&t=73244
Bronco II with a 2.3L swap http://fordsix.com/forum/viewtopic.php?f=13&t=72863
1988 F250 2x4, 460 ZF 5 speed.

Who is online

Users browsing this forum: No registered users and 12 guests