Turn sigs dont blink

Moderator: Mod Squad

Scuzzy_1250
Registered User
Posts: 29
Joined: Sun Mar 04, 2018 2:44 pm

Turn sigs dont blink

Post #1 by Scuzzy_1250 » Mon Jul 30, 2018 3:07 pm

So when I first got my hands on the 69 f100 six. It had a messed up harness from 4 owners of bad choices. One of the main problems was the lights. Original I didn't have any rear brakes or turn signals. So fast forward to a few weeks ago. I got my hands on a different Ford harness and cut all the bad wire out color for color. Everything works wonderful now. EXCEPT again my turn signals. When I turn them on they stay solid. No blinking. My relay is new and my tss is new. Lights work just no sigs. No flashing. And my front sigs and running lights. Do the same. I put my head lights on they front runners turn off and when I sig they don't flash only solid.

I got all my dash lights working dome light, cig lighter, no more lag in the start up, got rid of resistor wire, replaced some burnt up connectors. Lots of wires were grounding out cause of bad jackets.

I've changed everything except the missing Hazzard swtich. Cant find where I screwed up. Any suggestions where to look?

User avatar
bubba22349
Global Moderator
Posts: 8448
Joined: Sun Jan 03, 2010 4:46 pm
Location: Flagstaff, Az. 86005 near the old Route 66

Re: Turn sigs dont blink

Post #2 by bubba22349 » Mon Jul 30, 2018 5:40 pm

:hmmm: what year truck is it your working on?
A bad day Drag Racing is still better than a good day at work!

I am still hunting for a project car to build but with my current low budget it's not looking so good. My Ex- Fleet of Sixes these are all long gone! :bang: 1954 Customline 223 3 speed with O/D, 1963 Fairlane project drag car with BB6, 1977 Maverick 250 with C4, 1994 F-150 a 300 with 5 speed.

Scuzzy_1250
Registered User
Posts: 29
Joined: Sun Mar 04, 2018 2:44 pm

Re: Turn sigs dont blink

Post #3 by Scuzzy_1250 » Mon Jul 30, 2018 8:19 pm

1969 f100 240

User avatar
bubba22349
Global Moderator
Posts: 8448
Joined: Sun Jan 03, 2010 4:46 pm
Location: Flagstaff, Az. 86005 near the old Route 66

Re: Turn sigs dont blink

Post #4 by bubba22349 » Tue Jul 31, 2018 12:05 am

On those I think the hassard flasher is located behind the dash (Speed O Meter) panel. You might also try using a heavy duty flasher for the turn signals. Good luck :thumbup: :nod:
A bad day Drag Racing is still better than a good day at work!

I am still hunting for a project car to build but with my current low budget it's not looking so good. My Ex- Fleet of Sixes these are all long gone! :bang: 1954 Customline 223 3 speed with O/D, 1963 Fairlane project drag car with BB6, 1977 Maverick 250 with C4, 1994 F-150 a 300 with 5 speed.

Scuzzy_1250
Registered User
Posts: 29
Joined: Sun Mar 04, 2018 2:44 pm

Re: Turn sigs dont blink

Post #5 by Scuzzy_1250 » Tue Jul 31, 2018 8:29 pm

I did actually put in the new heavy duty one. But I guess I'll have to dive I to it once more. I bet it's something stupid like always.

One wire in the wrong spot or something

Scuzzy_1250
Registered User
Posts: 29
Joined: Sun Mar 04, 2018 2:44 pm

Re: Turn sigs dont blink

Post #6 by Scuzzy_1250 » Sat Aug 04, 2018 2:35 am

I got it fixed one wire switched hahaha like always something dumb hahaha

User avatar
bubba22349
Global Moderator
Posts: 8448
Joined: Sun Jan 03, 2010 4:46 pm
Location: Flagstaff, Az. 86005 near the old Route 66

Re: Turn sigs dont blink

Post #7 by bubba22349 » Sat Aug 04, 2018 8:23 am

:beer: yep many times it's so simple, congrats on finding and fixing it. :thumbup: :nod:
A bad day Drag Racing is still better than a good day at work!

I am still hunting for a project car to build but with my current low budget it's not looking so good. My Ex- Fleet of Sixes these are all long gone! :bang: 1954 Customline 223 3 speed with O/D, 1963 Fairlane project drag car with BB6, 1977 Maverick 250 with C4, 1994 F-150 a 300 with 5 speed.

Who is online

Users browsing this forum: No registered users and 3 guests