Click Here -> Please Consider Making a PayPal Contribution to the FordSix Forum!
2018 Contributors:
StarDiero75, curts56, DannyG, B RON CO, wsa111, Captainslow42, falconcritter
Econoline, THE FRENCHTOWN FLYER, 95FordFleetside, turbo6, Max_Effort, WorldChampGramp
cr_bobcat, C.S.Designs, pmuller9, gus91326, rwbrooks50, rocklord, drag-200stang, Big64my79Effie, CNC-Dude, gb500

2019 Contributors:
NJwpod, 1strodeo, mightynorseman, maxtrux, 6d7coupe, broncr, Phase3, 68Flareside240

Unknown->> S.Wickett, D.Blaine - Please PM me (1966Mustang) and lemme know who you are!

1952 Ammeter not working

Moderator: Mod Squad

Robdewey
New Member
Posts: 1
Joined: Fri Jul 20, 2018 2:16 pm

1952 Ammeter not working

Post #1 by Robdewey » Sun Aug 12, 2018 1:40 pm

I have a 52 Mainline that I've gotten everything working perfectly now except the ammeter. It just has one insulated wire that runs through an open loop on the back of the gauge then is connected to a post on multi post block. Looks to be all original setup, needle moves freely by hand, wire does have power when ignition is on but gauge never moves. Any thoughts or suggestions greatly appreciated. Thx Rob

Lazy JW
FSP Moderator
Posts: 5541
Joined: Fri May 16, 2003 10:25 pm
Location: Careywood, Idaho

Re: 1952 Ammeter not working

Post #2 by Lazy JW » Mon Sep 24, 2018 1:47 pm

The gauge is bad. I do not know where to get them repaired. Sorry. :cry:
"The White OX" 1974 F-350 300-6, Stock single exhaust, Carter YF, T-18A, Dana70 w/4.11, Flatbed dually w/dump bed. "Where no oxen are, the crib is clean, but much increase is by the strength of the ox" (Proverbs 14:4)
Image

User avatar
B RON CO
VIP Member
Posts: 760
Joined: Tue Apr 05, 2016 7:02 pm
Location: Long Island, NY
Contact:

Re: 1952 Ammeter not working

Post #3 by B RON CO » Tue Sep 25, 2018 4:03 pm

Hi, see if a moving a magnet along the back of the gauge will move the needle. The magnetic field will do the same thing as the electric field.
The gauges are rugged and foolproof.
A 35 amp gauge is pretty sensitive. A 60 amp gauge may only be moving a tiny amount.
If you just can't get it to work you will have to replace it.
good luck
B RON CO. Still workin' on it!

1933 Ford Pickup - 59A Flathead V8
1966 Ford Bronco - U14 - 170/200 Straight 6
1966 Ford Mustang - 289 V8

User avatar
wsa111
FSP Moderator
Posts: 3048
Joined: Sat Jan 24, 2004 5:28 pm
Location: South Carolina
Contact:

Re: 1952 Ammeter not working

Post #4 by wsa111 » Thu Oct 18, 2018 4:30 pm

Place an add for one in the wanted section of the forum. Check ebay.
https://www.macsautoparts.com/ford_truc ... FUQAvD_BwE
67 mustang,C-4, with mod. 80 hd, custom 500 cfm carb with annular boosters, hooker headers, dual exh.-X pipe, flowmaster mufflers, DSII dist. MSD-6al & TFI Coil. Engine 205" .030" over with offset ground crank & 1.65 roller rockers. 9.5 comp., Isky 262 cam.
2003 Ford Lightning daily driver. Recurving Distributors. billythedistributorman@live.com
Image

Who is online

Users browsing this forum: No registered users and 3 guests