Click Here -> Please Consider Making a PayPal Contribution to the FordSix Forum!
2018 Contributors:
StarDiero75, curts56, DannyG, B RON CO, wsa111, Captainslow42, falconcritter
Econoline, THE FRENCHTOWN FLYER, 95FordFleetside, turbo6, Max_Effort, WorldChampGramp
cr_bobcat, C.S.Designs, pmuller9, gus91326, rwbrooks50, rocklord, drag-200stang, Big64my79Effie, CNC-Dude, gb500

2019 Contributors:
NJwpod, 1strodeo, mightynorseman, maxtrux, 6d7coupe, broncr, Phase3, 68Flareside240, bmbm40,
mustang6, WorldChampGramp, justintendo, BigBlue94, ags290, motorsickle1130, Rooster, ousooner919, ethanperry

Unknown->> M.Ketterer, T.Smith, J.Myers, P.McIntire - Please PM me (1966Mustang) and lemme know who you are!

T5 Issues, Please Help

Moderator: Mod Squad

User avatar
StarDiero75
Registered User
Posts: 805
Joined: Tue Jun 13, 2017 9:39 pm
Location: Bremerton, WA

T5 Issues, Please Help

Post #1 by StarDiero75 » Sun Jul 14, 2019 3:15 am

Howdy guys,

I just finished putting a T5 in my 65 Ranchero with a 66' block so I'm using the 9" bell.

Currently I have a decent sized leak coming from the front of the trans. Its not dripping from inside the bell housing vents at the bottom. Here's what I've done:
•Put front shift tail housing on from MDL (required removing and reasealing the top cover and input bearing retainer)

I did notice it was missing a cap at the end of the shift rail, would this be a major leak? I didn't think it'd leak, i kinda thought it was just like that. But thinking back that might be it. I've been searching the internet and have found nothing on replacement top cover shift rail plugs.

Would it be a good idea to separate the trans and the bell a little and slide a paper gasket over the area its leaking, or put the gasket maker around that area?

Let me know what you all think,
Ryan
--1965 Ranchero w/1966 200 and 3.03 column shift, 8" rear 2.8 (Yes I know the gearing sucks), 1968 1.08 Autolite 2100 with VI adapter, CRT Performance HEI.
--1961 Studebaker Lark VI, OHV 170 l6 in the process of being resurrected. But it lives
--Creator of the only Weber 32/36 conversion video.

User avatar
chad
Registered User
Posts: 4649
Joined: Sat Oct 24, 2009 9:51 am
Location: Lawrence Swamp, S. Amherst, MA

New-to-me T5 has a leak

Post #2 by chad » Sun Jul 14, 2019 7:51 am

Seems like you may have trusted whajagod'n not gone over it before installation?

Don't know these T5s but many have a seal (U no, the kind U can remove w/1a those pullers, insert w/a driver or socket/other appropriate implement) &/or gaskets in the housing. May be the seal (inner unseen lip) is broken, it is in crooked, etc, the fasteners not tight or need covered w/that snot B4 inserted...

Is it overfilled?

Is the leak actually from another place & just dripping from transmission.
"Big thing is only make one change at a time. Change 2 or more things at a time it becomes difficult to figure which change helped or hurt" turbo2256b » 1/16/2017
Chad - '70 LUEB on '77 frame (i.e. PS, D44, trapezoidal BB 9", 4.11), 250, NV 3550 & DSII to B transplanted, "T" D20/PTO, 2" SL, 1" BL, 4 discs, 33"X15", tool boxes, etc. Seeking: Hydraulic gear motor for Koenig pto. chrlsful@aol.com (413) 259-1749

mustang6
VIP Member
Posts: 1432
Joined: Thu Oct 23, 2003 11:32 pm
Location: near Tacoma, WA USA

Re: T5 Issues, Please Help

Post #3 by mustang6 » Tue Jul 16, 2019 3:50 am

Take a look at this article with pictures.

http://www.mustangandfords.com/how-to/chassis-suspension/1904-rebuilding-a-t-5-five-speed-part-1-disassembly

Do you mean the big plug at the back of the shifter box housing? You can see in the pictures this T5 has one.
Scott

68 Mustang 200 ci, Aussie 250-2V head, Dual Headers, Comp Cams 252H, DSII w/MSD 6AL, T-5, V8 suspension.

65 Ranchero 200 ci, late 170 head, Autolite 1101, 3.03 3 speed, Maverick 8" 4 lug rear with 3.55 gears.

User avatar
StarDiero75
Registered User
Posts: 805
Joined: Tue Jun 13, 2017 9:39 pm
Location: Bremerton, WA

Re: T5 Issues, Please Help

Post #4 by StarDiero75 » Wed Jul 17, 2019 10:18 pm

mustang6 wrote:Take a look at this article with pictures.

http://www.mustangandfords.com/how-to/chassis-suspension/1904-rebuilding-a-t-5-five-speed-part-1-disassembly

Do you mean the big plug at the back of the shifter box housing? You can see in the pictures this T5 has one.

No i mean a plug that goes at the front of the transmission (see picture). It goes at the end of the shift rail. I just found a plug and will be trying to install it while still in the car.

Heres the hole I'm talking about
You do not have the required permissions to view the files attached to this post.
--1965 Ranchero w/1966 200 and 3.03 column shift, 8" rear 2.8 (Yes I know the gearing sucks), 1968 1.08 Autolite 2100 with VI adapter, CRT Performance HEI.
--1961 Studebaker Lark VI, OHV 170 l6 in the process of being resurrected. But it lives
--Creator of the only Weber 32/36 conversion video.

Who is online

Users browsing this forum: No registered users and 3 guests