It's alive. But runs like a total turd. Help?

Moderator: Mod Squad

User avatar
falcon_master
Registered User
Posts: 211
Joined: Fri Apr 21, 2017 1:25 pm

It's alive. But runs like a total turd. Help?

Post #1 by falcon_master » Thu Jul 19, 2018 12:37 am

Hi everyone. It's been awhile since I've posted. But in that time I have fixed the brakes and electrical. The car will stop but the pedal sinks almost all the way to the floor before the car starts to slow. But that's not a safety issue as the car won't even move more than 2 feet. The engine is running so bad. So what happens is it'll idle great and and won't sound like it's going to die. I rebuilt the carb myself. It was my first time so I have no idea what the float level is but the symptoms seem to point to fuel starvation. It'll idle great but when you start to rev up it starts missing alot. And it runs really rough and will start shaking the car worse than a jackhammer before it stalls. I don't here back firing and doesn't smell to rich to me. Any idea?
Junior year high school AFJROTC cadet and car enthusiast. Likes all things ford and engines of any company. 64 falcon 2dr sedan with 144 six and 3spd column shift manual transmission estimated 124,000 miles. Resurrected after sitting outside for 18 years, In process fixing for use as daily driver. “Old cars may break but are never broken”-RCR

User avatar
bubba22349
Global Moderator
Posts: 8315
Joined: Sun Jan 03, 2010 4:46 pm
Location: Flagstaff, Az. 86005 near the old Route 66

Re: It's alive. But runs like a total turd. Help?

Post #2 by bubba22349 » Thu Jul 19, 2018 1:48 am

:hmmm: have you done a compression test yet? Good luck :nod:
A bad day Drag Racing is still better than a good day at work!

I am still hunting for a project car to build but with my current low budget it's not looking so good. My Ex- Fleet of Sixes these are all long gone! :bang: 1954 Customline 223 3 speed with O/D, 1963 Fairlane project drag car with BB6, 1977 Maverick 250 with C4, 1994 F-150 a 300 with 5 speed.

frozenrabbit
Registered User
Posts: 118
Joined: Fri Feb 12, 2016 1:01 pm

Re: It's alive. But runs like a total turd. Help?

Post #3 by frozenrabbit » Thu Jul 19, 2018 10:47 am

When you rebuilt the carb, did you thoroughly clean it?

Where did you start at with adjustment on the idle mixture screw?

When you lost the check balls, did you loose the weight that goes on top of one of the check balls?

Have you put a timing light to it yet?

Is the vacuum advance diaphram holding vacuum on the distributor?
Last edited by frozenrabbit on Thu Jul 19, 2018 11:31 am, edited 1 time in total.

Soldmy66
Registered User
Posts: 339
Joined: Fri Jan 09, 2004 11:09 pm

Re: It's alive. But runs like a total turd. Help?

Post #4 by Soldmy66 » Thu Jul 19, 2018 11:01 am

You might want to start by looking at fuel filters.

The clog easily and although an engine will idle with a dirty fuel filter, the engine starves for fuel above idle.

User avatar
falconcritter
Registered User
Posts: 211
Joined: Sat Jul 02, 2005 10:45 pm
Location: Jagsonville

Re: It's alive. But runs like a total turd. Help?

Post #5 by falconcritter » Thu Jul 19, 2018 7:05 pm

My car was doing the same thing it sounds like . One easy check off of the list is ... take off the dizzy cap and with a flashlight check under the points plates for oil in the bottom of your dizzy ! On my car the oil was messing up my timing when driving . And at idle it was fine . Easy Check off of the list
1969 Ford Falcon 2Door and future home for an Australian 250 2V , 2013 Ford F-150 Single Cab , 2018 Ford Escape S

Who is online

Users browsing this forum: No registered users and 23 guests